Forum for iCal4OL, Print4OL and ICS4OL

Exchange of experiences / Erfahrungsaustausch / Get Help

You are not logged in.

Announcement

Verkauf von iCal4OL an Neukunden ist eingestellt! Keine Demo mehr verfügbar..
Diese Seite ist ausschliesslich für Kunden, welche auch noch zusätzliche Lizenzen kaufen können.
The selling of iCal4OL has ended! No trial available anymore..
This site is exclusively for customers, which may still want to buy additional licenses.

iCal4OL Version 2.16.6 is now available. See Announcements / Ankündigungen


#1 2014-08-02 13:55:54

Holg
New member
Registered: 2014-08-02
Posts: 2

Google und ICloud Down/Upload geht nicht "zusammen"

Ich möchte von Apples ICloud Plug-in auf ICAL4OL umsteigen und teste dies gerade in der Demoversion.
Primär möchte ich damit als erstes die Kontakte auf ICloud und Google damit über Outlook synchron halten.

Die Kontakte von Outlook werden richtig gezählt und geloggt, allerdings werden diese nicht hochgeladen und auch keine Kontakte von Googgle oder ICloud  "gedownloaded", auch wenn ich die Simulation ausschalte ändert das nicht.

Die Log-Datei offenbart mir keinen eindeutigen Fehler offenbart und suggeriert auch, dass die Verbindung richtig aufgebaut wurde. Stutzig mach mich nur die Meldung von Google in der Log-datei unmitellbar vor dem Download:


GETALL 403 Forbidden <?xml version="1.0" encoding="UTF-8"?>
<errors xmlns="http://schemas.google.com/g/2005">
<error>
  <domain>GData</domain>
  <code>forbidden</code>
  <internalReason>Cannot request contacts belonging to another user</internalReason>
</error>
</errors>

==> Download von Google Mail.


Hier der Auszug aus der CardDav Sync mit ICloud:
info=0, Connection #0 to host p02-contacts.icloud.com left intact

==> URL: https://p02-contacts.icloud.com:443/
==> Download   Cat: Add:
==> Upload   Cat:
==> ContactPictures, GroupCategories, AC=11, Dist=False
-----------------------------------------------------------------

<+> Herr XXX YYY <XXX@YYY.de>                  Neu - hochgeladen...
==> SIMULATION <==
-----------------------------------------------------------------
==> 02.08.2014 12:54:07

==> Gelesen: 0
<-> Übergangen: 0
<!> Gelöscht: 0
<+> Importiert: 0
==> Gelesen: 1
<-> Übergangen: 0
<!> Ex.Gelöschte: 0
<+> Exportiert: 1

info=0, Closing connection #0

info=0, SSLv3, TLS alert, Client hello (1):

info=6, 


und der Log Auszug mit Google:

info=0, Connection #0 to host www.google.com left intact

  } GETALL 403 Forbidden <?xml version="1.0" encoding="UTF-8"?>
<errors xmlns="http://schemas.google.com/g/2005">
<error>
  <domain>GData</domain>
  <code>forbidden</code>
  <internalReason>Cannot request contacts belonging to another user</internalReason>
</error>
</errors>

==> Download von Google Mail

==> Upload nach Google Mail
****************************DEBUG: XXX, XXX
Categories: Contacts;Privat
Before:
<entry xmlns='http://www.w3.org/2005/Atom' xmlns:gd='http://schemas.google.com/g/2005' xmlns:gContact='http://schemas.google.com/contact/2008'><category scheme='http://schemas.google.com/g/2005#kind' term='http://schemas.google.com/contact/2008#contact'/>...
                         Neu - hochgeladen...
-----------------------------------------------------------------
==> 02.08.2014 10:51:27


Die Einstellungen und logs würd ich gerne anhängen ich finde die Funktion hier im Forum aber nicht.

Offline

 

#2 2014-08-02 15:14:22

Roland
Administrator
Registered: 2007-11-25
Posts: 1516

Re: Google und ICloud Down/Upload geht nicht "zusammen"

Das darf nicht so konfiguriert werden. Es braucht etwas mehr Aufwand, um das so zum Laufen zu bringen.
Der Grund liegt darin, dass iCloud keine Änderungszeiten unterstützt (wie auch etliche CardDAV/CalDAV-Clients nicht), und
normalerweise geht nur eine 1-1 Beziehung zu genau einer Serverlösung. Dh. auch  die Sync-Felder kämen sich in die Quere..

Das Vergehen:  Genau so machen - alles zweimal lesen bis klar.... Keinen Sync dazwischen starten!

Es benötigt zwei *.ini Konfigurationsdateien.

Die Default.ini wird nun ausschliesslich für Google konfiguriert! Siehe dazu auch http://ical.gutentag.ch/Outlook-Google- … al4OL.html
Dazu in Default.ini den Assistenten [Google Konfigurationsassistent für  API v2/v3] auf Reiter "Wer" starten (damit auch alles zurückgesetzt wird)!
Hier ganz oben die Haupt-Gmailadresse (wie im Browserinterface von Google oben rechts sichbar) eintragen! Das war sicher bisher falsch!
- Alles so konfigurieren, als wollten Sie auch den Hauptkalender von Outlook synchronisieren, mit folgenden Änderungen:
  Auf der Zeile 3) für Google-Hauptkalender zusätzlich markieren    [X] Up  [X] Down    [X] S(imulation)   [X] Warne
  [X] Kontakte mitsynchronisieren                                                 [X] Up  [X] Down    [  ] S(imulation)   [X] Warne
- Am Schluss [Speichern] im Assistenten klicken.
Nun im Hauptfenster von iCal4OL auf den Reiter "Was" gehen und einen Doppelklick auf die grosse 2. mitte links machen, damit der Kalender-Sync unter 1. deaktiviert wird.
Soweit so gut - auf dem Reiter "Kontakte" unter CardDAV darf auch KEINEN FALL mehr was von iCloud stehen! Das darf nicht in dieser .ini konfiguriert werden!
Also Default.ini [Speichern] und im Prinzip kann jetzt der Gmail-Kontakte-Sync gleich schonmal gestestet werden. Sicherheitshalber mit Warnen, damit evtl. Änderungen in Outlook nicht überschrieben werden.
Weitere Details zu Gmail-Sync siehe http://ical.gutentag.ch/forum/viewtopic.php?id=42


Auf [Neu/Öffnen] klicken und iCloud.ini eingeben, damit eine leere zweite *.ini geladen wird.
Jetzt sehr wichtig: Auf Reiter "Optionen - Exchange/*.pst" gehen und dort einen speziellen Namen für die externe Sync-DB eingeben, wie zb.
==> Datenbankname (LEER=Userproperties.mdb) - nur für Experten: icloud.mdb

iCloud.ini nun [Speichern] und noch geladen lassen!
Nun den Assistenten [Andere] auf Reiter "Wer" aufrufen für die iCloud-Konfiguration. Siehe dazu auch http://ical.gutentag.ch/Outlook-iCloud- … al4OL.html
Auch hier mit [X] Simulation, und im Subfenster der gelisteten iCloud-Kalender-Colletion dann auch unbedingt [X] Warne aktivieren!
Den Assistenten druchrattern lassen, und dann zuerst im Hauptfenster von iCal4OL auf den Reiter "1. Wie" gehen:
- Hier sicherstellen, dass "[X] Nur Simulation" aktiv und auch das Flag "etag" im Feld KENNUNG steht (Gilt auch für CardDAV und bedeutet "[X] Warne"!).

Nun im Hauptfenster von iCal4OL auf den Reiter "Was" gehen und einen Doppelklick auf die grosse 2. mitte links machen, damit der Kalender-Sync unter 1. deaktiviert wird.
Soweit so gut - auf dem Reiter "Kontakte" unter CardDAV gehen und auch aktivieren dass [X] Mit Kalender-Synchronisation starten... aktiviert ist.
Noch nicht testen, sondern erst weiterlesen!!

Lesen über mehrfache *.ini Dateien hier: http://ical.gutentag.ch/faq.html#F1
Sie sollten nun wissen, wie Sie iCloud.ini in Default.ini verketten/laden etc.

Die Konfiguration hier habe ich sicherheitshalber mit "[X] Warne" vorgeschlagen! Ich weiss nicht, wo die aktuellen Kontakte zur Zeit stehen.
Beim erstem Sync mit iCloud gewinnt evtl. der iCloud-Kontakt. Dies falls keine Änderunszeit (REV:) eingetragen ist (wird wahrscheinlich auf NOW() gesetzt).
Auch hilft beim ersten Sync das Flag "etag" auf dem Reiter "1. Wie" nicht, da Outlook-Kontakte noch als unverändert interpretiert werden. Es gewinnt also das neuere Änderungsdatum.
==> Eben deshalb zuerst mal "[X] Mit Simulation" antesten, ob es gut kommt.

(Reiter "1. Wie" wird logischerweise wieder aktiv, indem auf Reiter "Was"
"[X] 2-Wege oder 1-Weg-Sync mit Weblösungen (CalDAV)" angekreuzt wird. Danach können die Flags für CalDAV/CardDAV verändert werden.
  ==> Aber das ist nur die halbe Wahrheit. Falls der Kalender-Sync deaktiviert ist, wird die Kennung von "[X] 2-Wege-Sync mit Google-Kalender" gelesen!
          Das spielt für iCloud keine Rolle, da iCloud automatisch erkannt wird - aber für andere Lösungen schon... die Kennung dort muss in diesem Falle = Kennung für CaldDAV gesetzt sein.
  Entsprechend in Default.ini eine Google-Sync-Art unter 1. aktivieren, falls der Kalender auch mitsynchronisiert werden soll.
  Nicht vergessen danach wieder auf "2." doppelzuklicken..)

Deshalb evtl. erst "[X] mit Simulation" auf dem CardDAV-Fenster testen, um sicherzugehen, dass keine Outlook-Kontakte mit altem Zeug überschrieben werden.

(Beim iCloud-CalDAV-Termin-Sync lässt sich vermeiden, dass beim ersten Sync die Server-Termine gewinnen. Dazu müsste Flag "older" mit Flag "newer" ersetzt werden. Also Outlook-Termine sollen beim ersten Sync als NEUER interpretiert werden.)

Wenn mal alles ok ist, könnte das "Warnen" für Gmail-Kontakte-Sync im Subfenster abgestellt werden, und für iCloud das Flag "etag" entfernt werden (siehe oben).




PS: Log.txt und *.ini nie im Forum veröffentlichen, sondern zumailen falls Support nötig!

Offline

 

#3 2014-08-03 01:47:01

Holg
New member
Registered: 2014-08-02
Posts: 2

Re: Google und ICloud Down/Upload geht nicht "zusammen"

Danke, hab noch mal alles von vorne gemacht und siehe da es geht zumindest jetzt mit Google.
Die Kombi probiere ich später aus.

Mein Fehler war, das ich nur den Reiter Kontakte gesehen und ausprobiert habe, da ich keine Termine synchronisieren wollte.
Es gab leider keinerlei Fehlermeldung das vorne auch etwas zu tun ist.
Der Reiter schien für sich alleine zu funktioniern, da viele Angaben auch dort angegeben werden.

Wenn mans weis ist ok, nur evtl. könnte man die redunandten Angaben reduzieren (z.B. E-Mail, Kennwort, Authorisierung), wenn man die Reiter von vorn nach hinten durchgeht macht man vieles mehrfach.

Nur so als Tipp.

Auf jeden Fall das Erste Programm, das Outlook und Google vermindet, das ich kenne, und das auch funktioniert.

Offline

 

#4 2014-08-06 10:24:31

Roland
Administrator
Registered: 2007-11-25
Posts: 1516

Re: Google und ICloud Down/Upload geht nicht "zusammen"

iCal4OL ist nunmal ein Kalender-Sync-Programm, wo CardDAV / Gmail-Kontakte nur zusätzlich unterstützt wird..

Das hier ist "nur" ein Trick. Es ist nicht angedacht, iCal4OL als nur Kontakte-Sync-Lösung zu verwenden!

Offline

 

Board footer