Forum for iCal4OL, Print4OL and ICS4OL

Exchange of experiences / Erfahrungsaustausch / Get Help

You are not logged in.

Announcement

Verkauf von iCal4OL an Neukunden ist eingestellt! Keine Demo mehr verfügbar..
Diese Seite ist ausschliesslich für Kunden.
The selling of iCal4OL has ended! No trial available anymore..
This site is exclusively for customers.

iCal4OL Version 2.17.1 is now available. See Announcements / Ankündigungen


#1 2009-02-15 16:35:17

Roland
Administrator
Registered: 2007-11-25
Posts: 1521

iCal4OL 2.7.5 Update for an Google API 2.0 Bug (English/German)

Dear Customers

Google updated the DATA API 2.0 to 2.1 - but unfortunately something went wrong, because the API version 2.0 is also affected by the changes, although this should not be (Incorrect detection of the HTTP requests, despite correctly set header "GData-Version: 2").

Specifically, there are now problems with the Google Sync Field "Date and time last run (will be set automatically)".
If this field is empty or the date is older than 26 days NO EVENTS will be found in the Google Calendar!

Only from iCal4OL Version 2.7.1 the new API 2.0 is used - older versions of iCal4OL are not affected (using API 1.0).

Please install the latest Version of iCal4OL to circumvent this bug (older dates than 26 days or empty field will get all events)!

With kind regards
Roland Scherrer

Offline

 

#2 2009-02-15 16:35:55

Roland
Administrator
Registered: 2007-11-25
Posts: 1521

Re: iCal4OL 2.7.5 Update for an Google API 2.0 Bug (English/German)

Liebe Kunden und Kundinnen

Google hat eine neue Data API Version 2.1 implementiert, aber dabei ist leider etwas schiefgegangen, denn die bisherige API-Version 2.0 wird von den Aenderungen auch betroffen, obwohl dies nicht so sein sollte (Fehlerhafte Erkennung der Http-Anfragen, trotz korrekt gesetztem Header "GData-Version: 2" gegenüber "GData-Version: 2.1").

Konkret gibt es nun Probleme beim Google Sync mit dem Feld "Datum und Zeit letzter Lauf (wird automatisch hochgesetzt)".
Ist das Feld leer, werden KEINE TERMINE im Google Calendar gefunden. Ist das Datum älter als 26 Tage, werden auch keine Termine mehr gefunden!

Da iCal4OL erst seit Version 2.7.1 die API 2.0 verwendet, sind ältere Versionen von iCal4OL nicht betroffen (verwenden API 1.0).

Bitte installieren Sie also die neueste Version von iCal4OL - dort wird dieser Bug umgangen (bei älterem Datum als 26 Tage oder LEER werden alle Termine gelesen)!

Mit freundlichen Grüssen
Roland Scherrer

Offline

 

Board footer